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A native macOS application that converts mixing sessions between Avid Pro Tools (.ptx) and Cockos 

Reaper (.rpp) in both directions. Runs entirely on the Mac — no Wine, no virtual machine, no Pro Tools 

licence required. Available as a standalone app from filmsound.ai (direct DMG, includes two Reaper 

extensions) or from the Mac App Store (sandboxed, no extensions). Both builds perform the same 

conversion.

Three ways to use it. The standalone app is the core — it does all the conversion, and everything 

in PT Reaper Converter app below describes it. The direct DMG also bundles two independent, 

optional Reaper extensions; you never need them (the app does everything), they are just shortcuts 

that live inside Reaper. The Mac App Store build has neither.

The app (standalone) DMG · App Store Converts .ptx ↔ .rpp, both directions. The whole 

PT Reaper Converter app section is about this.

Reaper extension 1

Import PTX

DMG only Opens a .ptx straight from Reaper’s Action list — 

skips the “convert to .rpp, then File → Open” 

round-trip.

Reaper extension 2

Spot to Pro Tools (Beta)

DMG only Sends the clips you selected in Reaper live onto a 

Pro Tools track, both apps open.

⚙️ One key difference — baking item FX

Only the Spot extension can bake Reaper item-level processing — item / take FX, playrate, 

pitch-shift, stretch, reverse — into the audio for you, from inside Reaper, as part of the spot. 

Converting a Reaper session to Pro Tools the ordinary way (the standalone app) does not bake 

it: those transforms live inside the Reaper items, not in the audio on disk, so you must bake the 

affected items in Reaper yourself first (see the item-level processing tip in PT Reaper 

Converter app). This concerns the Reaper → Pro Tools direction only — a Pro Tools session 

coming the other way has no Reaper item FX. The app converts what’s already baked; only 

Spot bakes for you.

Quick start

1. Drop a .ptx or .rpp file onto the input slot, or use Browse. The converter auto-detects 

direction from the extension.

2. Pick an Output mode — Link to source (light, references originals) or Copy Media 

(Standalone) (self-contained bundle). The output path preview updates underneath.

3. Click the funnel icon to filter what gets converted (automation, playlists, markers — defaults 

convert everything). Click the gear in the top-right corner to customise default folder names for 

processed audio / video files (used in both Link and Standalone modes; in Link mode for any 

derivatives the converter has to create, in Standalone for everything copied into the bundle).

4. Click Convert. The output file appears in the chosen folder, ready to open in the destination 

DAW.
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Installation

Direct DMG. The disk image contains the app, two Reaper extensions, and two drop targets:

PT Reaper Converter.app Drag onto Applications (the symlink on the right side).

reaper_ptx_import.dylib The import extension — opens a .ptx straight into Reaper (PTX → 

Reaper). Drag onto REAPER UserPlugins (the alias on the right 

side). The alias points at ~/Library/Application Support/REAPER/

UserPlugins/.

reaper_pt_spot.dylib The Spot to Pro Tools extension — sends selected Reaper clips 

into a running Pro Tools session (see Spot to Pro Tools below). 

Drag onto REAPER UserPlugins as well.

Both extensions are optional and independent — install whichever workflow you use, or both. The 

drag targets (Applications, REAPER UserPlugins) are aliases shown on the right side of the DMG 

window.

If macOS Gatekeeper blocks the first launch (“the developer cannot be verified”), Control-click the 

app in Applications and choose Open once. From then on it launches normally. The DMG and app are 

notarized by Apple, so on macOS 14+ this prompt should not appear.

Mac App Store. Install like any other app. The App Store build is sandboxed and does not include 

the Reaper extensions — use the standalone-app workflow (convert in the app, then open the 

resulting .rpp in Reaper).

Requirements. macOS 14 Sonoma or later (the Spot to Pro Tools extension requires macOS 15 

Sequoia or later). Universal binary — Apple Silicon and Intel. Reaper 6 or later for the extensions 

(Reaper 7 recommended for the most accurate fade and lane rendering).

Trial and licence

The unlicenced (Trial) build trims clips, fades and automation past the first two minutes from the 

earliest clip. Track count, bus structure, routing, channel layout, panning, markers and tempo are not 

limited — you see the full session structure even in Trial, just with shortened audio.

Activation works differently depending on where you got the app:

• Direct DMG. Open the licence sheet (the Activate License button at the bottom of the main 

window), paste the key you received by email after purchase on filmsound.ai, and click Activate. 

The key is tied to your machine and is verified online once; afterwards the app runs offline.

• Mac App Store. The purchase is handled by Apple — there is no licence-key field. After buying 

through the in-app Buy button, the app is licensed for any Mac signed in with the same Apple 

ID.

💡 Already bought on the App Store? Use it on the Direct DMG too.

The Reaper extensions and the earliest updates are Direct-only, so you may want the Direct 

build even after buying in the App Store — and you don’t need to buy again. The App Store app 

shows your licence key in Preferences → Account (a copyable XXXX-XXXX-XXXX-XXXX). Copy 

it, download the Direct DMG from filmsound.ai, open its licence sheet and Activate with that 

key — exactly like a direct purchase. The same key works on your machines up to its device 

limit.
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Reaper extension 1 — Import PTX into Reaper

Optional · direct DMG only · reaper_ptx_import. The first of the two bundled Reaper extensions. It 

adds an action that opens a .ptx straight into Reaper, so you skip the “export an .rpp from the app, 

then File → Open” round-trip. The standalone app does the identical conversion — this extension is 

purely a convenience, and you don’t need it to convert.

The extension installs an action, not a File-menu entry. Cockos Reaper does not let third-party 

extensions modify the built-in menus directly, so the entry point is added through Reaper’s Action list 

— from there you can run it, bind a shortcut, or place it in a menu yourself.

1. Quit Reaper completely (menu → Quit Reaper, or ⌘Q) if it was running when you copied the 

dylib.

2. Re-launch Reaper. Open Actions → Show action list….

3. In the filter field type PTX. You should see Import PTX Session Data… in the results.

4. Select the action and choose one of:

• Run — executes the action once.

• Add shortcut — bind a keystroke for repeat use.

• Customize menus / toolbars (under the Action list’s gear menu) — add the action to the 

File, Extensions or any custom menu.

If the action does not appear in the list, the extension didn’t load. Check:

• The dylib is in ~/Library/Application Support/REAPER/UserPlugins/. The DMG alias points 

there, but if you dragged it elsewhere by mistake, Reaper won’t find it.

• Reaper was fully quit (not just closed) before the dylib was copied. New extensions are only 

scanned at launch.

• REAPER → About REAPER → Plug-ins lists reaper_ptx_import and shows it as loaded. If it 

appears with an error, send the error text to support.

Reaper extension 2 — Spot to Pro Tools (Beta)

🧪 Beta feature

This is an early-access tool under active development. It works on real sessions today, but the 

option set is still growing and the behaviour may change between builds. Feedback welcome at 

filmsound.ai.

Optional · direct DMG only · reaper_pt_spot. The second bundled Reaper extension. It sends the 

clip(s) you have selected in Reaper straight onto a track in a running Pro Tools session — no manual 

export, no file dialog. Both apps stay open. The clips arrive in Pro Tools carrying their clip gain, 

volume / pan / surround-panner automation, and fades and crossfades, and the Pro Tools routing 

is left untouched. Unlike the standalone app, it can also bake Reaper item-level processing for you 

before sending (see Baking item FX before the spot below).

What it needs:

• macOS 15 (Sequoia) or newer. The Spot extension requires macOS 15+ — note this is higher 

than the rest of the app, which runs on macOS 14+. On macOS 14 the converter and the import 

extension work normally, but Spot will not load.

• PT Reaper Converter installed (the app from this same DMG — the extension reaches Pro 

Tools through it).
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• Pro Tools running with a session open — the spot uses Pro Tools’ own Import Session Data 

under the hood.

• reaper_pt_spot.dylib in ~/Library/Application Support/REAPER/UserPlugins/ (the DMG 

installs it alongside reaper_ptx_import).

Opening the panel

Like the import extension, this adds an action — it does not touch Reaper’s menus. Open Actions → 

Show action list… and search for PT/RPP: Spot selection to Pro Tools. Its default shortcut is the 

grave / backtick key (top-left of the keyboard, next to the 1 key), unmodified and rebindable. Running 

the action:

• with clip(s) selected — spots them immediately, using your saved options;

• with nothing selected — opens the Spot to Pro Tools panel so you can set options first.

The panel header shows the connected session — Pro Tools version, sample rate, frame rate and 

session name. If it reads “Pro Tools: not reachable (open a session?)”, bring a Pro Tools session 

into focus and it reconnects on its own.

The three-step spot

1. In Pro Tools, click the target track at the position you want — that track selection plus the edit 

cursor are where the clips land.

2. In Reaper, select the clip(s) to send.

3. Press the shortcut (or the SPOT to Pro Tools button in the panel).

A Preflight readout above the button tells you, before you commit, exactly what will happen — green 

is ready, orange is an automatic adjustment you should know about, red needs your attention.

Panel options

Spot mode Free — the clips land on the track(s) you have selected in 

Pro Tools, in order. Match by track name — each Reaper 

track’s clips land on the Pro Tools track of the same name 

(like PT’s own Import Session Data match).

Create missing PT tracks When on, any Reaper track without a Pro Tools target is 

created as a new Pro Tools track instead of being skipped. 

New tracks come in without an output assignment — set 

their output in Pro Tools afterwards (the preflight flags this 

in orange).

Spot position At cursor — clips land at the Pro Tools edit-cursor 

timecode. Reaper TC — clips land at their own Reaper 

timeline position, for conforming a mirror session.

Pro Tools follows Reaper’s cursor Live link: while on, moving Reaper’s edit cursor moves the 

Pro Tools timeline in real time (one-way, Reaper → Pro 

Tools). Off by default; turns off when you close the panel.

Media Link — Pro Tools references the source audio where it 

lives. Copy — Pro Tools copies it into the session’s Audio 

Files folder. Non-Pro-Tools-native files are converted to 

WAV and force Copy automatically.

Existing clips Overlay — keeps what is already on the target track. 

Replace — clears the target track first.
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Baking item FX before the spot

The spot links each clip’s raw source file, so anything Reaper computes on playback — item / take FX, 

playrate, pitch-shift, stretch markers, a reversed take, or an inverted polarity — would be lost on the 

Pro Tools side. The panel detects these clips and offers to bake them first: each is rendered to a new 

take at its own channel count (mono stays mono), committing those effects while leaving track FX 

out and keeping clip gain as a separate value. A short handle is rendered around each clip so effect 

tails and edges stay clean. This is non-destructive — the original take is kept alongside the new one, 

your source files on disk are untouched, and the bake is undoable with ⌘Z. Rendered files go to a PT 

Spot Baked folder next to the project.

• The Bake button lights orange when the current selection has clips that need it, and is greyed 

when there is nothing to bake.

• Tick Auto-bake before spot to have it happen silently as part of each spot.

• Settings… sets the Handle length (pre/post-roll) and offers Clean up baked files to remove the 

PT Spot Baked folder when you are done.

This automatic baking is unique to the Spot extension. When you convert a Reaper session to Pro 

Tools with the standalone app instead, those item-level transforms are not baked — bake the affected 

items in Reaper yourself first (see the item-level processing tip in PT Reaper Converter app).

Settings — what rides along

The Settings… popover (under Options & Filters) holds the What to spot switches. With Main output 

routing left off (the default) the Pro Tools track’s routing is preserved. Currently available:

• Clip gain

• Volume automation

• Pan automation

• Surround panner automation

Further switches (clip effects, plug-in assignments, sends) are shown greyed — they are not yet 

available in this beta.

Good to know

• Clip format must match the target track — mono onto a mono track, stereo onto stereo, 7.1.2 

onto 7.1.2, and so on. A mismatch is flagged red in preflight and Pro Tools may reject it.

• Video clips are skipped — the spot is audio-only (the preflight reports how many were left out).

• A sample-rate or frame-rate difference between the two sessions is reported in preflight: clips 

still land by time, but timecode may not match frame-for-frame, and Pro Tools may sample-rate-

convert the material.

• Known issue (being fixed): spotting onto a track that already has automation can clear existing 

automation to the right of the spotted clip (the clips themselves are kept). Until this is resolved, 

spot onto tracks without automation you need to keep past the spot point, or re-draw the 

affected automation afterwards.

PT Reaper Converter app

The sections from here on describe how conversion behaves — output modes, automatic file handling, 

the preflight, and exactly what carries across in each direction. The engine is the same however you 

trigger it: the standalone app, the import extension, or the Spot extension all convert identically. (Spot 

adds the bake step described in Extension 2 everything else is shared.)
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Output mode: Link vs Standalone

Both directions of conversion have the same two file-handling modes, picked via the Link to source / 

Copy Media (Standalone) tabs in the Output section. Both the standalone app and the Reaper 

extension share this control.

Link to source. The output project references the original files at their current absolute paths; originals 

are never touched. This works even when your audio is spread across several different folders, or 

across different drives — a shared sound library on another drive, a separate rendered or bounced 

folder, and your project media can all be in different places, and each file is referenced at its own real 

path. Files that are offline at conversion time keep their paths too, so the destination DAW can relink 

them later. Output is small, no copy step. By default the converter saves the output project right next 

to the source (toggle off “Save in same folder as source” to pick a different folder). The session file 

name auto-fills from the source name and is editable. Pick this for in-house work where the audio 

doesn’t travel.

Copy Media (Standalone). Self-contained bundle: a new folder named after the source session is 

created at the chosen output path, containing the project file plus an audio sub-folder (defaults: Media/ 

for Reaper output, Audio Files/ for Pro Tools output). On the Pro Tools side the converter stamps an 

Avid Unique ID into each WAV’s BWF + UMID chunk so PT relinks correctly even after the bundle is 

moved. A separate Copy video files checkbox copies video into the bundle too — leave it off (default) 

for multi-GB clips that can stay on external storage. The bundle name auto-fills from the source name 

and is editable.

Folder names for audio + video are user-configurable — click the gear icon in the top-right corner of 

the main window to set defaults per direction (Pro Tools side: typically Audio Files + Video Files; 

Reaper side: typically Media). These names are used in BOTH modes: in Link mode for any processed 

derivative files the converter has to create (split-mono merges, resamples, transcodes), and in Stand

alone for everything copied into the bundle. Setting audio and video to the same value collapses both 

into one folder, useful for editors who keep everything under Audio Files/. Preferences apply to both 

the standalone converter and the Reaper extension automatically.

When Standalone is on AND the output folder collides with the source audio folder, the conversion 

is blocked in preflight to prevent overwriting originals; switch to Link mode or pick a different output 

folder.

Automatic conversions in both modes. Some sources are not directly playable by the destination 

DAW. The converter normalises all of those automatically — you don’t need to toggle anything for it to 

happen. Converted files land in the project’s audio folder regardless of Standalone state; the originals 

stay untouched.

Both directions Split-mono channel pairs (name.L.wav + name.R.wav) are merged into a 

single interleaved file. The merged file uses the stripped base name 

(no .L/.R suffix). On the PT side, AIF source files are forced to WAV at merge 

time.

Reaper → PT only Sample-rate mismatches with the session: the file is resampled to the 

session rate and saved with a _sr<kHz> suffix (e.g. kick_sr48.wav for a 44.1 

→ 48 kHz conversion). Lossy and non-native formats (FLAC, OGG, MP3) 

are transcoded to WAV with a _pt suffix (e.g. vox.flac → vox_pt.wav). 

Reaper plays Pro Tools’ WAV / AIF natively at any rate, so no equivalent step 

is needed in the PT → Reaper direction.

In Standalone mode these conversions happen alongside the verbatim copies of every other file. In 

Link mode only the files that actually needed conversion appear in the output’s audio folder; everything 

else is referenced in place.
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💡 Get the cleanest Link-mode output

Before converting, consolidate your source audio so that every file is interleaved WAV at the 

session’s sample rate. With nothing to merge, resample or transcode the converter has zero 

work to do in Link mode — no extra files are created, no Audio Files/ / Media/ folder appears 

next to the output, and the resulting project links directly at every original source.

💡 Cleanest Pro Tools → Reaper preparation: Save Copy In

Before converting, let Pro Tools normalise every source file to a single uniform format. In Pro 

Tools: File → Save Copy In…, set Audio File Format to BWF (.WAV), pick one bit depth and 

one sample rate for the whole session, and tick Interleaved (not split-mono). Pro Tools then 

writes a fresh copy of every audio file with a proper WAVEFORMATEXTENSIBLE channel mask 

for any multichannel material. Point the converter at this freshly-saved session. The choice of bit 

depth or sample rate doesn’t matter — what matters is that Pro Tools itself normalises every file 

in one pass, so Reaper sees a consistent, mask-tagged set of sources with no out-of-band 

quirks left over from imported / older material.

💡 Bounce Reaper item-level processing before converting (Reaper → Pro Tools)

The converter translates timeline / track structure, clip placement, fades, clip gain, clip mute / 

colours / names, track and clip-level pan automation, ReaSurroundPan, and item channel-mode 

(CHANMODE) selection of a single source channel (Mono (Left), Mono (channel N)) or a stereo 

pair (Stereo 1/2, Stereo N/N+1). It does not yet translate per-item processing that lives inside 

Reaper items — Item FX (per-clip plug-in chains), take FX, take envelopes, stretch markers 

and time-stretching, per-item pitch shift, PLAYRATE (item playback rate), Mono (downmix) 

and Reverse stereo channel modes, reversed items, and multiple takes within one item. 

Anything in this list is silently dropped or flattened on conversion. (Looped items are the 

exception — they convert: see Looped clips in the Reaper → Pro Tools table.) The clean 

solution for the rest is to bake it into the audio in Reaper first: Item → Render items as new 

take (including take FX) for each affected item, then convert from the rendered result. This 

freezes every Reaper-specific transform into a fresh take, so what Pro Tools sees is exactly what 

plays back in Reaper.

Video. In Standalone mode the Copy video files checkbox controls whether video tracks are copied 

into the bundle’s video folder (default Video Files/, configurable in Preferences) or left referenced 

at their original path. Default off — video is typically multi-GB and the destination DAW can link by 

absolute path even when video lives on an external drive.

Preflight and Relink

Before every conversion the app reads the source session, walks every clip and pool entry, and shows 

a Preflight Report with the session’s vital statistics (sample rate, frame rate, tempo, length, track 

counts, file counts, Pro Tools or Reaper version) and any compatibility warnings: missing audio files, 

missing video files, unsupported plug-ins, mixed-format tracks that will be auto-split, tracks above 12 

channels, etc. Nothing is written to disk at this stage — you can change settings or cancel without 

consequences.

If files are reported missing or in the wrong location, click Relink… on the preflight panel to open the 

Relink dialog. The dialog lists every unresolved file and lets you point at its current location on disk (file-
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by-file or by choosing a single replacement folder that the app searches recursively). A replacement 

can live anywhere, including a different drive; the location you pick is written into the converted session, 

so even a file that is still offline relinks correctly on the other side. Resolved files are remembered for 

this conversion only — the source .ptx / .rpp itself is never modified.

This is especially useful when you don’t have a Pro Tools licence at hand: you can take a .ptx from 

a colleague, verify in seconds that every audio and video file is reachable, relink whatever moved 

between machines, and then convert without any “missing media” surprises on the other side. The 

same applies in the opposite direction — checking a .rpp for missing renders / take pools before 

producing the .ptx avoids silently-incomplete sessions reaching Pro Tools.

The Preflight Report also flags structural issues the converter cannot fix automatically — for example 

a Reaper track holding clips in two incompatible channel layouts will be split into separate tracks in 

Pro Tools, and the preflight tells you which tracks and how. Address those in the source DAW before 

converting if the auto-handling isn’t what you want.

Pro Tools → Reaper

The converter reads the .ptx directly (no AAF or OMF round-trip needed) and emits a .rpp project 

file. Audio is either referenced in place from Pro Tools’ Audio Files folder (Link mode) or copied into 

a Media/ folder next to the .rpp (Standalone mode) — see Standalone vs Link mode above.

What converts

Tracks & clips Audio, Aux Input, Routing Folder and Video tracks. Clips with positions, lengths, 

mute, colours, names.

Fades Fade-ins, fade-outs and crossfades, with the original curve shape preserved 

(concave / linear / convex).

Clip gain Both static dB values and dynamic breakpoint envelopes.

Automation Track Volume, Pan, Mute and send automation (slots A–J).

Routing Output, input and send routing. Sub-path buses (5.0, LCR, LFE). Folder-based 

routing with full nesting.

Surround 5.1, 7.1 and 7.1.2 surround panners as ReaSurroundPan, with both static 

positions and dynamic automation.

Playlists Pro Tools playlists become Reaper Fixed Item Lanes (audio and video).

Timeline Markers (Memory Locations with names and colours), tempo map, time 

signature changes.

Visual Track colours, clip colours, track notes (via the SWS extension), solo state, solo 

safe.

Audio files WAV, AIF and RF64. Split-mono pairs (.L/.R) merged into interleaved stereo. 

Polyphonic files use iXML for channel naming.

Routing

Pro Tools’ mixer hierarchy is mapped to Reaper folder tracks: tracks sharing an output bus are grouped 

under a single folder track in the destination project. This handles sub-paths, multi-receiver buses, 

and nested folders faithfully for film and music sessions alike — no user toggle needed.
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Reaper → Pro Tools

Conversion in this direction writes a complete Pro Tools session bundle that opens in Pro Tools 11 and 

later. The bundle contains the .ptx, an Audio Files folder, and (if your project uses video) a Video 

Files folder or a path reference to the original.

What converts

Tracks Audio, Folder and Video tracks. Reaper tracks that receive sends are 

converted as Pro Tools Aux Input tracks automatically.

Clips Positions, lengths, mute, colours, names. Fades and crossfades with curve 

shape preserved.

Looped clips A Reaper looped item (one that repeats its source to fill a longer item) is 

recreated in Pro Tools as the equivalent run of consecutive clips, since Pro 

Tools has no per-clip loop. The repeats carry the same audio, the original 

fade-in stays on the first clip and the fade-out on the last, and the clip gain 

— static or dynamic — is reproduced across the whole run.

Clip gain Static and dynamic. The value shown over the clip in Reaper (the gain 

handle) and the volume set in the clip’s Item Properties window are 

combined into one Pro Tools clip gain.

Automation Track Volume, Pan, Mute on all converted tracks.

Routing The Reaper folder hierarchy is recreated as Pro Tools routing folders with 

the same nesting; buses are auto-created where needed. The Reaper 

Master track always becomes a Pro Tools Master Routing Folder (RF). 

Multichannel routing follows the Reaper master / parent channel count.

Surround 3.0 / 4.0 / 5.0 / 5.1 / 7.1 / 7.1.2 via ReaSurroundPan, with both static slider 

positions and full automation. For LFE the converter reads the value from 

the first channel only of the Reaper panner and writes it into the Pro Tools 

panner’s single LFE knob (Pro Tools has one LFE control even for stereo 

sources, so the Right-channel LFE in Reaper is intentionally ignored).

Audio & video files See Standalone vs Link mode above. The converter auto-normalises 

mixed-rate audio, FLAC / OGG / MP3 and split-mono pairs in both modes. 

Video formats actually supported by Pro Tools on 

Mac: .mov, .mp4, .m4v, .mxf.

Timeline Tempo, time signatures, project markers (with names and colours) become 

Pro Tools Memory Locations.

Visual Track notes, colours, solo state, solo safe.

Preflight Before conversion the app shows a report of incompatible features, missing 

files and warnings. A Relink dialog lets you point at moved sources without 

touching the project.

Common questions

My Pro Tools mono track came through as 6-channel in Reaper

This is correct. Reaper has no concept of a “mono track” — every Reaper track has at least 2 channels, 

and any track that needs to play out of a 5.1 destination must itself be 6-channel. So when a Pro Tools 

mono track is routed to a 5.1 bus or directly to the 5.1 Main / Control Room output, the converter 

widens the Reaper track to 6 channels and inserts a ReaSurroundPan with the mono input locked to 
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the correct speaker (CR.L, CR.C, CR.LFE, CR.Ls, CR.Rs, etc.). The audio plays out of the exact same 

physical speaker as in the Pro Tools session.

If you wanted the converted Reaper project to play in surround, make sure Reaper’s Preferences 

→ Audio → Device output channel count matches your speaker layout (6 for 5.1, 8 for 7.1, etc.) — 

otherwise Reaper will downmix internally and you’ll lose the routing.

Fades sound different from Pro Tools

Since version 1.5.5, fade curve shapes are preserved on both directions of conversion: concave, 

linear and convex slopes for fade-ins, fade-outs and crossfades open in the other DAW with the same 

audible curvature. Earlier versions wrote a generic equal-gain curve regardless of the source, which 

looked similar on screen but sounded flat. Re-convert older sessions with 1.5.5+ to pick up the shape 

mapping.

The two extreme square-block shapes from Pro Tools’ fade dropdown (top and bottom items) are not 

produced — they’re musically unusable and clamped to the nearest curved shape.

Pro Tools shows my files as “missing” or asks to relink

Two likely causes:

• Source files moved after conversion. If you used Link mode and then moved the 

converted .ptx to another machine or rearranged the source folders, Pro Tools can’t find them 

— Link mode references files by path. Audio that was spread across several folders or drives at 

conversion time (a library on another drive, a separate rendered folder, your project media) is 

referenced correctly at each file’s own path, so a multi-folder layout itself is not a cause — the 

only failure mode is moving the files afterwards. Use Standalone mode for portable sessions (it 

copies the files into the bundle and writes Avid Unique IDs so relink works automatically).

• Files were renamed after Standalone conversion. Pro Tools matches Standalone-bundled 

files by Avid Unique ID, not by filename, so the Relink dialog in PT will offer the right candidates 

and you can confirm one by one.

Sample-rate or format mismatches (mixed-rate sources, FLAC / OGG / MP3, split-mono pairs) are 

not a relink cause — the converter normalises all of those automatically in both Standalone and Link 

modes. Files that need conversion are emitted into an Audio Files/ folder next to the .ptx with a 

_sr<kHz> (resampled) or _pt (transcoded) suffix; the originals stay untouched. You don’t need to toggle 

anything for this to happen.

My video doesn’t open in Pro Tools

Pro Tools on Mac reliably opens .mov, .mp4, .m4v and .mxf (with a supported codec). .avi and .mkv 

are detected as video by the converter — so the track is created correctly — but Pro Tools on Mac 

cannot decode them. Re-encode such clips to .mp4 (H.264) or .mov (ProRes) before conversion.

If the video is online and Pro Tools still shows it offline, the file may have a non-standard MP4 layout 

(moov atom at the end of file). Versions 1.5.4 and later handle that case automatically.

“Some clips were trimmed” or boundaries warnings after PT opens my session

Since version 1.7.1 (build 78) the converter clamps every clip to its source file’s real length before 

writing, so this Pro Tools warning should no longer appear on conversion. A genuine Reaper loop that 

ran past the source end is now reproduced as repeated clips instead of being trimmed (see Looped 

clips in the Reaper → Pro Tools table). If you still see the warning on an older converted session, re-
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convert it with the current version, or run the session through File → Save As… → New copy in Pro 

Tools once to let PT re-write the references.

Where do I send a bug report?

In the app: Help → Report a bug… opens a pre-filled email. Or directly to info@filmsound.ai. 

Please include the version (visible in About PT Reaper Converter), a short description of what you 

expected vs what happened, and — ideally — a small reproducer session. Sessions under 25 MB can 

be attached directly; larger ones via Dropbox / Drive / WeTransfer link.

What is on the roadmap?

Currently surfaced as preflight warnings, planned for upcoming releases: Reaper-side send slots A–

J as Pro Tools sends, Reaper Fixed Item Lanes / Takes as Pro Tools playlists, Master Fader track 

conversion, MIDI tracks and clips (both directions), full plug-in chain conversion (only ReaSurroundPan 

converts today), Atmos extended surround formats (5.1.2, 5.1.4, 7.1.4, 7.1.6, 9.1.4, 9.1.6), tick-based / 

beat-locked tracks, and per-track options to skip or keep inactive and hidden tracks.

PT Reaper Converter is developed and maintained by filmsound.ai.

Updates and support: https://filmsound.ai/pt-reaper · info@filmsound.ai

Includes zstd © Meta Platforms, Inc. and affiliates (BSD-3-Clause).
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